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Descripci¶on de algunas t¶ecnicas para eliminar y reparar efectos indeseados
en fotograf¶³a en soporte digital usando el programa Adobe Photoshop

1 Ajuste del rango de color

El rango de color de una imagen digital corresponde a la distribuci¶on de colores
de ¶esta, comenzando por los pixels m¶as oscuros y acabando por los m¶as claros.
Para que la distribuci¶on de colores de la imagen sea ¶optima y ¶esta presente el
mejor contraste posible, es necesario que los pixeles m¶as oscuros sean negros
y los m¶as claros sean blancos. En caso contrario,existir¶a un n¶umero m¶as o
menos elevado de colores que no se utiliza y, por tanto, los colores de los pixeles
restantes ser¶an m¶as parecidos.

Cuando se sacan fotograf¶³as en lugares oscuros o cuando ¶estas presentan
sobreexposici¶on al °ash o a una fuente de luz intensa, el rango de color de la
fotograf¶³a resultante suele reducirse considerablemente, mezcl¶andose todos los
tonos oscuros o claros seg¶un sea el caso. En realidad, las diferencias de color
siguen estando en la imagen, pero al recortarse el rango son muy peque~nas y
el observador no puede apreciarlas. El proceso por el que se corrigen estos
problemas se conoce como h istogram stretching o aumento de contraste.

El Adobe permite llevar a cabo esta operaci¶on mediante su corrector de
niveles. Para acceder a dicha herramienta, hay que seleccionar en el menu
Image > Adjust > Levels, lo que hace aparecer el panel de niveles. Dicho
panel muestra la distribuci¶on de tonos de la imagen, presentando picos en los
colores que m¶as se repiten. Su estremo izquierdo corresponde al negro y el
derecho al blanco. Las im¶agenes que requieren un ajuste del rango de color
son f¶aciles de detectar porque o bien no presentan valor alguno en los extremos
o bien presentan un pico en dichos extremos y una zona sin valores entre los
extremos y el grueso de la distribuci¶on.

Para alterar el rango de color de una imagen usando el panel de niveles,
basta con arrastrar los tri¶angulos blanco y negro situados bajo la curva hasta
los puntos donde la distribuci¶on comienza a crecer. Por ejemplo, la Fig. 1.a
presenta una fotograf¶³a tomada al atardecer. Puede observarse que los detalles
de la zona sombreada se han perdido y, tal como cab¶³a esperar, su panel de
niveles muestra una descompensaci¶on hacia colores oscuros (Fig. 1.b). En este
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caso, aparecen dos picos: uno correspondiente al cielo, de color m¶as claro, y otro
al resto de la imagen. La zona central no tiene valor alguno y puede observarse
que el pico de la izquierda no comienza exactamente en el negro. Si desplazamos
el negro hasta el comienzo del primer pico y el tri¶angulo blanco hasta el ¯nal de
¶este, obviando el segundo pico, la imagen queda tal como se ve en la Fig. 1.d,
mostr¶andose su nueva distribuci¶on de color en la Fig. 1.c.

Figure 1: Aumento de contraste: a) foto original; b) histograma original; c)
histograma arreglando; d) foto retocada

2 Luces y sombras

Las herramientas b¶asicas para controlar la luz y la sombra en una imagen son
el a juste de contraste y el de luminosidad. Estas herramientas se encuentran
en el menu Image > Adjustments > Brightness¡ Contrast. La luminosidad
es una caracter¶³stica de la imagen que permite precisar si ¶esta es m¶as clara o
m¶as oscura. Cada pixel tiene su propio valor de brillo en una imagen, pero
esta herramienta en particular s¶olo permite controlar la luminosidad de forma
global. Esto signi¯ca que todas las zonas aumentar¶an o disminuir¶an su lumi-
nosidad en una misma cuant¶³a. La Fig. 2.b muestra como afecta un aumento
de luminosidad a la foto de la Fig. 2.a.

El aumento de contraste trata de que las diferencias se marquen tanto como
sea posible. Esto implica que en una fotograf¶³a los oscuros se har¶an m¶as oscuros
y los claros m¶as claros. Naturalmente, este tipo de herramienta no es aplicable
a im¶agenes con colores planos, donde no hay luces ni sombras que resaltar. La
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Fig. 2.c muestra el efecto de un aumento de contraste sobre la foto de la Fig.
2.a.

Figure 2: Aumento de luz y contraste: a) foto original; b) aumento de luz; c)
aumento de contraste

Los procedimientos expuestos hasta ahora permiten manipular de forma
global las luces y sombras de una imagen, pero en la mayor¶³a de las ocasiones
resulta m¶as ¶util llevar a cabo estas manipulaciones de forma local y controlada.
Para ello suelen usarse capas de color. Para insertar una capa sobre una imagen,
basta escoger la opci¶on del menu Layer > NewLayer o la combinaci¶on de teclas
CTRL+SHFT+N. La capa insertada es transparente y, por tanto, no afecta a la
imagen en absoluto. Una capa es el equivalente a superponer una transparencia
sobre una imagen. Todo lo que se escriba sobre dicha transparencia aparecer¶a
sobre la imagen, pero dicha imagen queda inalterada. En particular, las capas
presentan una ventaja adicional: sus modos de acoplo. Variando ¶estos puede
cambiarse el efecto de la capa sobre el fondo. Por ejemplo, puede hacerse que
lo que haya en la capa s¶olo afecte al blanco o al negro.

Para iluminar de forma local determinadas ¶areas de una imagen, debe in-
sertarse una capa nueva y cambiar su modo de acoplo (blending) a luz suave
(soft light). Esto puede hacerse con el panel de capas (Fig. 3.d). Una vez se
ha generado la mencionada capa, basta utilizar la herramienta aer¶ografo con
una tinta clara para pintar sobre las ¶areas que se desean iluminar. La Fig. 3.b
muestra una capa de este tipo con los retoques necesarios para iluminar los ar-
cos centrales de la imagen de la Fig. 2.a. Tal como puede observarse, s¶olo se
han pintado de blanco las mencionadas zonas. Mientras la capa est¶e en modo
normal, se ver¶an los trazos blancos sobre la fotograf¶³a. Cuando se cambie a
modo luz suave, el efecto es el que aparece en la Fig. 3.a.
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Figure 3: Aumento de luz y sombras selectivo: a) foto retocada; b) capa de luz;
c) capa de sombra; d) acoplo de capas

De forma similar, se pueden incrementar las sombras en una imagen. Para
ello, se pintar¶an con el aer¶ografo en colores oscuros las zonas a sombrear. La Fig.
3.c muestra un ejemplo de una capa de este tipo. En este caso, el modo de acoplo
de la capa debe ¯jarse a "Overlay". En la Fig. 3.a se observa el efecto de la
capa mencionada, que consiste en oscurecer los bordes de la imagen. N¶otese que
no debe usarse el modo de acoplo Oscurecer (Darken) para obtener sombras,
ya que enmascara lo que hay debajo.

3 Correcci¶on de color

En muchas ocasiones, determinadas fotograf¶³as presentan efectos indeseados de
desplazamiento del color, apareciendo verdosas, pardas, azuladas o blanqueci-
nas de forma global (Fig. 4.a). Cuando ¶esto ocurre, los colores que aparecen
en la fotograf¶³a no son los reales, pero tienen la ventaja de estar todos dis-
torsionados en aproximadamente la misma cuant¶³a. Gracias a ello, es posible
recuperar los colores originales sin apenas distorsi¶on alguna de forma muy sen-
cilla. Para ello, crearemos una capa de ajuste a efectos de no alterar la imagen
original en caso de equivocaciones. Las capas de ajuste se crean con la opci¶on
de men¶u Layer > N ew Adjustment Layer. Estas capas son de distintos tipos
y permiten que la imagen sobre la que se superponen re°eje los efectos de las
operaciones equivalentes que se llevan a cabo sobre la capa, pero sin alterar el
original. Por ejemplo, una capa de ajuste de contraste permite variar el con-
traste de la imagen, pero si el resultado no es satisfactorio basta con eliminarla
para recuperar la imagen original. Ademas, utilizando capas de ajuste pueden
a¯narse los efectos de estas sobre la imagen original variando su transparencia.

El m¶etodo m¶as f¶acil para llevar a cabo esta operaci¶on consiste en crear una
nueva capa de ajuste tipo Hue=Saturation. Con esta capa puede corregirse en
tono global de la imagen. Una vez se selecciona la opci¶on de insertar este tipo de
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capa, aparece el panel de la Fig. 4.b, donde puede alterarse la proporci¶on global
de magenta, celeste y amarillo de la imagen. De esta forma, pueden cambiarse
los valores hasta obtener un resultado aceptable a la vista.

El principal problema de la t¶ecnica anterior es que en ocasiones puede ser
lento dar con la combinaci¶on adecuada de las tres variables disponibles. Como
alternativa, puede usarse una capa de ajuste de niveles para corregir la infor-
maci¶on. En este caso, el panel que aparece al a~nadir la capa es el de la Fig.
4.c, ya comentado en el apartado de aumento de contraste. Para corregir el
color, en este caso, se pueden utilizar las herramientas cuentagotas situadas a la
derecha del panel. Esta herramienta permite indicarle al programa qu¶e pixeles
son blancos y cuales son negros. Si toda la imagen se ha desplazado en una
misma cuant¶³a hacia un color, como es el caso habitual, al indicarle qu¶e color
es el blanco o el negro, el propio programa se encarga de corregir el resto de
los colores en consonancia. Igualmente, si existe un gris neutro en la imagen,
es interesante indicarselo al programa usando el cuentagotas gris para que ¶este
efectue un ajuste mas ¯no. La Fig. 4.c muestra los efectos de la t¶ecnica expuesta
sobre la fotograf¶³a de la imagen Fig. 4.a. Puede observarse que los resultados
son mejores que en la Fig. 4.b, adem¶as de m¶as r¶apidos. No obstante, para
mejorar los resultados, es recomendable efectuar un ajuste del rango de color
previo a aplicar esta t¶ecnica si la imagen as¶³ lo requiere.

Figure 4: Correcci¶on de color: a) foto original; b) capa de ajuste de tono; c)
capa de ajuste de niveles
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4 Efectos de ¯ltro

Una herramienta habitual de fotogra¯a son los ¯ltros de colores, que permiten
intensī car las luces en una escena. Por ejemplo, puede hacerse el cielo m¶as
azul o el sol m¶as anaranjado usando el ¯ltro adecuado, Alternativamente, puede
usarse el Adobe Photoshop para conseguir el mismo efecto con una ventaja
adicional: no tiene por qu¶e aplicarse un ¶unico ¯ltro para toda la imagen.

El ¯ltro permite ajustar el color de una imagen al tono deseado sin preocu-
parse por el color que presentaba antes pero manteniendo la forma de los objetos.
Para aplicarlo a una zona determinada, previamente debe seleccionarse dicha
zona mediante la herramienta correspondiente. Una vez la zona se encuentra
seleccionada en su totalidad, se inserta una nueva capa de ajuste de la forma
ya descrita. En este caso, la capa ser¶a de tipo Hue=Saturation, asegur¶andose
de marcar la casilla "Colorize", situada en la esquina inferior derecha. Una vez
marcada esta casilla, los deslizadores de tono, saturaci¶on y brillo permitir¶an ¯jar
el color de los pixeles bajo la capa al color deseado. Es importante notar que
esta variaci¶on de tono tiene unos l¶³mites impuestos por el color original. Por
ejemplo, un marr¶on claro no podr¶a transformarse en un rojo intenso sin que el
resultado quede arti¯cial.

La Fig. 5.a muestra una fotograf¶³a donde el color del agua va a alterarse
utilizando la t¶ecnica expuesta. La Fig. 5.b muestra el panel de la capa de
ajuste de tono donde ya se ha marcado la casilla colorize. Desplazando los
deslizadores, puede variarse el color del agua a azules m¶as intensos (Fig. 5.c) o
a verdosos (Fig. 5.d), sin que se aprecien grandes diferencias. Si se desea, puede
experimentarse con los modos de acoplo de la capa de ajuste para conseguir
distintos efectos de luz sobre el fondo.

5 Eliminaci¶on de defectos

En ocasiones, una foto puede presentar un n¶umero inde¯nido de defectos o im-
perfecciones. Por ejemplo, las fotos antiguas puede presentar grietas o manchas.
Igualmente, el efecto del °ash o la incidencia de la luz del sol sobre la lente
pueden provocar la aparici¶on de colores indeseados que enmascaran el fondo.
Cuando estos defectos no son muy grandes o no se encuentran directamente
sobre un ¶area de detalles, se pueden eliminar f¶acilmente. Evidentemente, la
t¶ecnica a continuaci¶on no servir¶³a para una mancha que cubra en gran parte
la cara de una persona ya que no se dispondr¶³a de informaci¶on su¯ciente para
reconstruirla. Sin embargo, casos aparentemente complejos como el de la Fig.
6.b pueden eliminarse casi por completo.

Las mencionadas manchas son f¶acilmente eliminables si se encuentran sobre
super¯cies de color homog¶eneo: bastar¶³a seleccionarlas y rellenarlas con el color
apropiado. El problema surge cuando se encuentran sobre super¯cies texturadas
como el oceano en la Fig. 6.b. En estos casos, el Photoshop ofrece una her-
ramienta que permite clonar la textura de los p¶³xeles adyacentes sobre la zona
manchada. La Fig. 6.a muestra la barra de herramientas del programa con la
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Figure 5: Efectos de ¯ltro: a) foto original; b) capa de ajuste de tono; c)
desviaci¶on al celeste; d) desviaci¶on al verde

herramienta "Clonar" (Clone) activada. En este caso, es necesario seleccionar
la primera opci¶on (C lone Stamp Tool). A continuaci¶on, situ¶andose en una zona
cercana a la mancha pero con los colores correctos, se pulsa la tecla ALT y
se presiona el bot¶on. Esta operaci¶on permite indicarle al programa de donde
se desea que copie los p¶³xeles con que se va a escribir sobre la zona afectada.
Una vez se dispone de esta informaci¶on, basta pintar con la herramienta sobre
la mancha para que ¶esta adquiera la textura de la zona indicada. La Fig. 6.c
muestra el resultado del proceso sobre la imagen ejemplo.

Si se dispone de la ¶ultima versi¶on del Photoshop, una vez concluida la
clonaci¶on puede procederse a usar la herramienta de reparaci¶on (H ealing Brush
Tool, en la barra de herramientas justo sobre la de clonaci¶on. Esta funciona
de forma parecida, pero menos agresiva y permite corregir los tonos de la zona
afectada para que se note menos la repetici¶on de patrones.

6 Suavizado de ruidos

En ocasiones, al escanear una imagen o capturarla con calidad no adecuada,
puede aparecer una cantidad de ruido considerable. Dicho ruido distorsiona la
imagen especialmente la imprimirla y, aunque no se aprecie completamente a
simple vista, puede observarse perfectamente en los canales rojo, azul o verde.
La Fig. 7.a muestra una fotograf¶³a de este tipo donde el canal verde y el azul
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Figure 6: Eliminaci¶on de manchas: a) barra de herramientas; b) fotograf¶³a
original; c) fotograf¶³a corregida

(Fig. 7.b) son considerablemente ruidosos.
En realidad, este tipo de fallos es muy simple de reparar. Para ello, basta

duplicar el fondo creando una nueva capa sobre la imagen. Dicha capa se suaviza
mediante un ¯ltro gaussiano. Puede usarse un factor de 6, por ejemplo. La
imagen debe quedar muy suavizada, pero reconocible. En el ejemplo de la Fig.
7.a, la capa resultante quedar¶³a como en la Fig. 7.b. Una vez se dispone de esa
capa, hay que cambiar el modo de acoplo a "Color". Ello supone que las zonas
de color se ver¶an afectadas por la capa superior, pero se conservar¶an las luces
y las sombras. Una vez aplicado este cambio, el ruido de la imagen se reduce
considerablemente, tal como se observa en el canal azul en la Fig. 7.d.

En ocasiones, la operaci¶on anterior puede no ser su¯ciente para obtener el
efecto deseado. Si ese es el caso, puede duplicarse la capa con la imagen ¯ltrada
de forma que ahora haya tres capas. El modo de acoplo de la capa superior
debe ajustarse entonces a normal, pero para que la fotograf¶³a no se vea alterada
en exceso, se ¯jar¶a su transparencia a un 30 % aproximadamente. La Fig. 8.b
muestra el efecto de esta segunda capa sobre la fotograf¶³a tratada.

Por ¶ultimo, es posible que las operaciones expuestas provoquen una p¶erdida
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Figure 7: Suavizado de ruidos: a) fotograf¶³a original; b) canal azul; c) capa
superior con suavizado gaussiano; d) resultado sobre el canal azul

de detalles indeseada en determinadas ¶areas. Para ello, puede insertarse sobre el
resto una ¶ultima capa que se genera a partir de una copia de la imagen original.
Una vez se dispone de la mencionada capa, se puede visualizar su panel de acoplo
pulsando dos veces sobre ella en la ventana de capas. Dicho men¶u presenta el
aspecto de la Fig. 9.a. Puede observarse que en la parte inferior del men¶u
aparecen dos barras de desplazamiento que indican bajo qu¶e circunstancias se
produce el acoplo. B¶asicamente, permiten ¯jar qu¶e zonas van a afectar a las
capas inferiores y cuales no. En el presente caso, s¶olo las zonas de detalle deben
acoplarse y, para ello, basta desplazar el tri¶angulo blanco de la izquierda hasta
aproximadamente el centro de la barra. Si se situa una capa completamente
blanca debajo de ¶esta -que luego habr¶a que eliminar- simplemente para ver el
efecto de la mencionada operaci¶on, los resultados ser¶an los de la Fig. 9.b. Como
puede observarse, s¶olo las zonas de detalle se propagan hacia abajo. No obstante,
esta transici¶on es muy brusca y, por tanto, indeseable. Para hacerla m¶as suave
se divide el tri¶angulo blanco en dos partes pulsando ALT y haciendo click sobre
¶el. La parte inferior se desplaza hacia el tri¶angulo negro hasta obtener el efecto
deseado, tal como muestra la Fig. 9.b.
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Figure 8: Suavizado de ruidos: a) fotograf¶³a original reparada por capa de color;
b) fotograf¶³a reparada pof capa de transparencia

Figure 9: Aumento de detalles: a) panel de acoplo de capa; b) paso alto brusco;
b) paso alto suave
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